Drupal

The Drupal exploiter exploits CVE-2019-6340 on a vulnerable Drupal server.

Description

Some field types do not properly sanitize data from non-form sources in certain versions of Drupal server.

This can lead to arbitrary PHP code execution in some cases.

Affected Versions

  • Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10.

One of the following conditions must hold:

  • The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests; OR
  • The site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7.

Notes

  • The Infection Monkey exploiter implementation is based on an open-source Python implementation of the exploit by @leonjza.
  • For the full attack to work, more than one vulnerable URL is required.